System Requirements

GovReady-Q is a Python 3.6 and higher, Django 2.x application with a relational database back-end.

Software Requirements

Required Python Software Packages (partial list)

(GovReady-Q application)

Python 3.6

Django 3.07

Jinja 2.x

uwsgi 2.x

unzip

graphviz

libmagic

filetype

pandoc

supervisor

Required Frontend Frameworks

jquery/Ajax 3.5.1

quill 1.3.7

bootstrap 3.4.1

Optional Software Packages (partial list)

Wkhtmltopdf

Git 2.x

Supported Databases

Postgres 9.4 (psycopg2 2.7.5 adapter)

Mysql 7.6 and higher (mysqlclient 1.3.12 adapter)

SQLite 3.x

Recommended Database

Postgres 9.4 (psycopg2 2.7.5 adapter)

SMTP Mail Server (for sending email notifications and receiving comments via email)

Any SMTP mail server (MTA) supporting STARTTLS connections.

For a more detailed list of software dependencies and requirements see:

Hardware Requirements

Minimum Hardware

Single server to host both multi-tenant GovReady-Q application and Database

Linux-compatible hardware

2GB RAM

10 GB storage (for database)

Recommended Hardware

2 servers: 1 for multi-tenant GovReady-Q application; 1 for Database Server

Linux-compatible hardware (64 bit architecture; FIPS-140-2 validated cryptographic module)

8GB RAM for each server

100 GB storage (for database server)